Deepin当前系统环境安装运行genymotion安卓模拟器

不能完成无法做到。
我认识到这件事,不能完成无法做到。这是基于当前我所能或得的知识和有限时间内的探索得出的认知,这是基于知识整体的认知。这类认知也要记录一下,为了避免无谓的探索和认识的反复性,人的精力是有限的,认识主体是有限的。发展到一定阶段自然能解决。
当前系统Deepin 15.4 .1(4.9.0-deepin12-amd64 #1 SMP PREEMPT Deepin 4.9.40-3 (2017-09-19) x86_64 GNU/Linux)
安装genymotion 当前最新版本2.10,官方要求VirtualBox是5.0.28,从深度商店中能获得的是5.1.28. 官方5.0.x不支持了。
卸载5.1.28,安装VirtualBox 5.0.28,genymotion启动会报出错误:未安装VirtualBox。粗略的了解到低版本的VirtualBox 需要在当前系统Deepin 15.4 .1(4.9.0-deepin12-amd64 #1 SMP PREEMPT Deepin 4.9.40-3 (2017-09-19) x86_64 GNU/Linux)上运行,要重新编译内核模块。(也许不复杂,但我现在没做过,也不想再挖坑去摸索)。发展到genymotion更新版本,恰好支持当前支持的VirtualBox 5.1(不去更新了),问题可解决。
VirtualBox 5.1.28 运行兼容问题,会在genymotion 2.10启动后,模拟器出现Android字样后卡死,是整个系统卡死。粗略了解到是兼容问题,也有人再Ubuntu 16.04下通过启用另一个显卡,而非Navida的显卡解决了问题。
还了解到genymotion要使用原生的硬件,再虚拟机中的操作系统上安装是不行的。
从Deepin社区、StackOverflow社区等问题资源来看,缺少解决途径,资源不足。
顾定性为不能完成无法做到。